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HNAS Dedupe Job Failing with "Failed to Open an Existing Index"

Updated 09/17/2024 08:36:32 PM by hvuser
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Content

Symptom

  • 5902 Warning       2017-09-21 19:29:38 Dedupe: Failed to start daily incremental job on file system 'dev_nfs_qt_home'.

  • 5905 Warning       2017-09-21 19:29:38 Dedupe: Error occurred on file system 'dev_nfs_qt_home'. Failed to open an existing index (path: /mnt/lb/evs3/fs-by-id/882a3d5b42ba04330000000000000000/$__DEDUPE__/albireo/index/incremental/882A3D5B42BA04330000000000000000, namespace: 882A3D5B42BA04330000000000000000), error Grid server status request timed out.

Environment

  • Hitachi Network Attached Storage (HNAS)

Resolution

  1. If this alert has only occurred once and the file system is not at immediate risk of filling up, wait 24 hours for the next scheduled run of deduplication. Depending on the specific issue in regards to open the deduplication index, it is possible that this is a one-time issue that will resolve on its own upon the next deduplication job.
  2. If the errors are persisting, please contact support to request a HNAS DEV password. When opening the SR, please provide the output of HNAS CLI command: pn all getmacid
  3. After support has provided you with the DEV password, please run the following to enable/log-in as DEV user and correct the inconsistent dedupe index.
    1. devuser on
    2. logout
    3. login dev <INSERT DEV PASSWORD>
    4. fs-dedupe-index-invalidate <INSERT FILESYSTEM NAME> incremental
  4. Wait for the next scheduled run of this dedupe job and verify that the dedupe now completes successfully. If you are still running into any issues or had problems running the DEV command to clear the index, please contact support for next steps.

Cause

The HNAS uses an index for incremental dedupe jobs. If the HNAS is having issues accessing this index, this can cause dedupe to fail so the resolution is to invalidate that problematic index and allow the HNAS to build a new index upon the next deduplication job.

CXone Metadata

Tags: Deduplication,Dedupe,5905,5902,Failed to open an existing index

PageID: 32074

Keywords: https://knowledge.hitachivantara.com/Knowledge/Storage/Network_Attached_Storage/HNAS_Dedupe_Job_Failing_with_Failed_to_Open_an_Existing_Index

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Solution ID
240403050032074
Last Modified Date
09/17/2024 08:36:32 PM
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